Author Topic: Strange HDD Problem  (Read 2902 times)

0 Members and 1 Guest are viewing this topic.

Offline casper

  • Administrator
  • Board Veteran
  • *****
  • Posts: 5212
  • Gender: Male
    • http://www.niaviation.co.uk
Strange HDD Problem
« on: February 24, 2015, 11:21:23 AM »
Have a laptop and it's going through the 'boot loop' - can't start properly, select Safe Mode, last known good configuration etc. Before I attempted anything I took the drive out and put it in to a pc as a secondary drive and copied its contents to an external drive. I also ran a disk check on it while it was in the pc and this brought up no errors.
Put it back in to the laptop and it still goes through the loop. Rebooted and went in to the Bios and there's a HDD test function. Ran it and it reported no errors.
Booted from a Windows XP disk and selected 'Repair' - this throws up an error saying there's no hard drive installed.
Repaired the MBR with a repair disk that I have (BartPE) but still the XP disk says there's no HDD installed???


Any ideas?
Northern Ireland Aviation Forum and Gallery
Aviation Photos
I don't think you're stupid, I think what you do is stupid.

Offline Stephen

  • Board Veteran
  • *****
  • Posts: 5743
  • Gender: Male
    • Banbridge Academy Online
  • Speciality: Black Neck sixth Dan - No Kan Do
Re: Strange HDD Problem
« Reply #1 on: February 24, 2015, 11:57:12 AM »
Boot loops are usually caused by a corrupt startup file - which you know anyway.
Maybe the XP boot disk doesnt have the right driver to handle the HDD or controller. Very unusual.
One looks back with appreciation to the brilliant teachers, but with gratitude to those who touched our human feelings. The curriculum is so much necessary raw material, but warmth is the vital element for the growing plant and for the soul of the child.
Carl Jung

Offline casper

  • Administrator
  • Board Veteran
  • *****
  • Posts: 5212
  • Gender: Male
    • http://www.niaviation.co.uk
Re: Strange HDD Problem
« Reply #2 on: February 24, 2015, 12:15:34 PM »
Turns out it was a registry problem - sorted :)
Northern Ireland Aviation Forum and Gallery
Aviation Photos
I don't think you're stupid, I think what you do is stupid.